[webkit-reviews] review denied: [Bug 102662] DFG should be able to cache closure calls : [Attachment 175107] the patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 19 19:21:05 PST 2012


Oliver Hunt <oliver at apple.com> has denied Filip Pizlo <fpizlo at apple.com>'s
request for review:
Bug 102662: DFG should be able to cache closure calls
https://bugs.webkit.org/show_bug.cgi?id=102662

Attachment 175107: the patch
https://bugs.webkit.org/attachment.cgi?id=175107&action=review

------- Additional Comments from Oliver Hunt <oliver at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=175107&action=review


r-, i'd like the armv7 errata removal in a separate patch as it makes it
difficult to see exactly what is relevant to this patch (also i don't like
playing mix-and-match with back and front end code changes :D )

>> Source/JavaScriptCore/dfg/DFGRepatch.cpp:1230
>> +	PassRefPtr<ClosureCallStubRoutine> stubRoutine = adoptRef(new
ClosureCallStubRoutine(
> 
> Local variables should never be PassRefPtr (see
http://webkit.org/coding/RefPtr.html).	[readability/pass_ptr] [5]

Style bot is right on this count, should be a RefPtr


More information about the webkit-reviews mailing list