[webkit-reviews] review granted: [Bug 101859] Use prefix form of increment / decrement operators in WTF String classes when possible : [Attachment 173509] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 12 12:26:35 PST 2012


Benjamin Poulain <benjamin at webkit.org> has granted Christophe Dumez
<christophe.dumez at intel.com>'s request for review:
Bug 101859: Use prefix form of increment / decrement operators in WTF String
classes when possible
https://bugs.webkit.org/show_bug.cgi?id=101859

Attachment 173509: Patch
https://bugs.webkit.org/attachment.cgi?id=173509&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=173509&action=review


Consistency is good and we are already in a period of coding style patches :)

> Source/WTF/wtf/text/StringImpl.cpp:1863
> -    terminatedString->m_length--;
> +    --terminatedString->m_length;

I'd argue this one becomes harder to read with the change.
I would prefer with parenthesis or with the old form.


More information about the webkit-reviews mailing list