[webkit-reviews] review granted: [Bug 101380] Autoresize should work even if turned on while the page is loading. : [Attachment 172836] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 7 10:53:04 PST 2012


David Levin <levin at chromium.org> has granted Fady Samuel
<fsamuel at chromium.org>'s request for review:
Bug 101380: Autoresize should work even if turned on while the page is loading.
https://bugs.webkit.org/show_bug.cgi?id=101380

Attachment 172836: Patch
https://bugs.webkit.org/attachment.cgi?id=172836&action=review

------- Additional Comments from David Levin <levin at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=172836&action=review


> Source/WebCore/ChangeLog:11
> +

Typically in WebKit, the changelog has some small per function comments as well
to explain why a change was done there.

I'll add some below as an example. I would suggest adding them or something of
this sort to your change log.

> Source/WebCore/ChangeLog:13
> +	   (WebCore::FrameLoader::checkCompleted):

Adjust to function rename.

> Source/WebCore/ChangeLog:15
> +	   (WebCore::FrameView::handleLoadCompleted):

Rename function to encompass its expanded responsibilities (which include doing
the final auto size after the load is completed).

> Source/WebCore/ChangeLog:16
> +	   (WebCore::FrameView::autoSizeIfEnabled):

Allow the size to shrink if autosize is adjusted while the page is loading.

> Source/WebCore/ChangeLog:18
> +	   (FrameView):

Function rename.


More information about the webkit-reviews mailing list