[webkit-reviews] review denied: [Bug 74111] Some overlay scrollbar API calls in ScrollAnimatorMac can lead to an assertion in RenderBox::mapAbsoluteToLocalPoint : [Attachment 145022] Fix 2 + manual test that asserts

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 31 08:38:59 PDT 2012


Simon Fraser (smfr) <simon.fraser at apple.com> has denied Ion Rosca
<rosca at adobe.com>'s request for review:
Bug 74111: Some overlay scrollbar API calls in ScrollAnimatorMac can lead to an
assertion in RenderBox::mapAbsoluteToLocalPoint
https://bugs.webkit.org/show_bug.cgi?id=74111

Attachment 145022: Fix 2 + manual test that asserts
https://bugs.webkit.org/attachment.cgi?id=145022&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=145022&action=review


> ManualTests/scrollbar-crash-on-hide-scrolled-area.html:33
> +    <a href="#" class=​"nextStepButton"
onclick="document.getElementById('toHide').style.display='none'">​Next
step​</a>​

There are still some non-ascii characters here. The testcase could be cleaned
further.

> Source/WebCore/platform/mac/ScrollAnimatorMac.mm:1239
> +void ScrollAnimatorMac::startNotifyContentAreaScrolledTimer()
> +{
> +    m_notifyContentAreaScrolledTimer.startOneShot(0);
> +}

It would be slightly cleaner to move the isActive check in here, and rename
this method to 'sendContentAreaScrolledSoon' or something. Then you don't need
the notifyContentAreaScrolledTimerIsActive() method, which has a confusing name
anyway.


More information about the webkit-reviews mailing list