[webkit-reviews] review granted: [Bug 86498] [EFL][DRT] LayoutTestController does not implement originsWithApplicationCache : [Attachment 144495] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 31 06:33:18 PDT 2012


Gustavo Noronha (kov) <gns at gnome.org> has granted Jussi Kukkonen
<jussi.kukkonen at intel.com>'s request for review:
Bug 86498: [EFL][DRT] LayoutTestController does not implement
originsWithApplicationCache
https://bugs.webkit.org/show_bug.cgi?id=86498

Attachment 144495: Patch
https://bugs.webkit.org/attachment.cgi?id=144495&action=review

------- Additional Comments from Gustavo Noronha (kov) <gns at gnome.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=144495&action=review


> Source/WebKit/efl/WebCoreSupport/DumpRenderTreeSupportEfl.cpp:686
> +    HashSet<RefPtr<WebCore::SecurityOrigin>, WebCore::SecurityOriginHash>
origins;
> +    WebCore::cacheStorage().getOriginsWithCache(origins);
> +
> +    HashSet<RefPtr<WebCore::SecurityOrigin>,
WebCore::SecurityOriginHash>::const_iterator it;
> +    HashSet<RefPtr<WebCore::SecurityOrigin>,
WebCore::SecurityOriginHash>::const_iterator end = origins.end();
> +
> +    JSValueRef jsOriginsArray[origins.size()];
> +    uint i = 0;
> +    for (it = origins.begin(); it != end; ++it) {
> +	   JSStringRef originJS =
JSStringCreateWithUTF8CString(it->get()->databaseIdentifier().utf8().data());
> +	   jsOriginsArray[i++] = JSValueMakeString(context, originJS);
> +    }

Consider using HashSet::copyToVector and using only the uint counter for more
readability.


More information about the webkit-reviews mailing list