[webkit-reviews] review granted: [Bug 82163] Scrollable plugins not registered properly in ScrollingCoordinator : [Attachment 133866] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 26 12:36:47 PDT 2012


Anders Carlsson <andersca at apple.com> has granted James Robinson
<jamesr at chromium.org>'s request for review:
Bug 82163: Scrollable plugins not registered properly in ScrollingCoordinator
https://bugs.webkit.org/show_bug.cgi?id=82163

Attachment 133866: Patch
https://bugs.webkit.org/attachment.cgi?id=133866&action=review

------- Additional Comments from Anders Carlsson <andersca at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=133866&action=review


> Source/WebCore/page/scrolling/ScrollingCoordinator.cpp:142
> +Region ScrollingCoordinator::nonFastScrollableRegion()
> +{
> +    return computeNonFastScrollableRegion(m_page->mainFrame()->view());
> +}

This change seems unrelated.

> Source/WebCore/page/scrolling/ScrollingCoordinator.h:118
> +    Region nonFastScrollableRegion();

Ditto.

> Source/WebCore/plugins/PluginViewBase.h:56
> +    virtual bool scrollable() { return false; }

I think this should be called wantsWheelEvents instead, since a plug-in may
want wheel events without being scrollable.


More information about the webkit-reviews mailing list