[webkit-reviews] review granted: [Bug 82082] [SOUP] Implement missing methods in CookieJarSoup : [Attachment 133546] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Mar 23 14:13:46 PDT 2012
Martin Robinson <mrobinson at webkit.org> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 82082: [SOUP] Implement missing methods in CookieJarSoup
https://bugs.webkit.org/show_bug.cgi?id=82082
Attachment 133546: Patch
https://bugs.webkit.org/attachment.cgi?id=133546&action=review
------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=133546&action=review
Nice! Consider reverting the changes to deleteCookiesForHostname and
deleteAllCookies. The old style seemed a more explicit about what was
happening.
> Source/WebCore/platform/network/soup/CookieJarSoup.cpp:128
> + // FIXME we are currently passing false always for seesion because
there's no API to know
Missing a ':' after FIXME.
> Source/WebCore/platform/network/soup/CookieJarSoup.cpp:149
> + CString cookieName = name.utf8();
> +
Extra newline here.
> Source/WebCore/platform/network/soup/CookieJarSoup.cpp:165
> + GOwnPtr<SoupCookie> cookie(static_cast<SoupCookie*>(item->data));
It's was actually a bit tricky for me to see how this worked now, with a
GOwnPtr assigned the cookie late in its life. I'm not sure if I prefer this
approach versus the old one.
> Source/WebCore/platform/network/soup/ResourceHandleSoup.cpp:164
> - setDefaultCookieJar(jar);
> + setSoupCookieJar(jar);
I think your new name is far more appropriate.
More information about the webkit-reviews
mailing list