[webkit-reviews] review granted: [Bug 81492] Use CSSPrimitiveValue::convertToLength() in a few places. : [Attachment 132546] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 20 16:05:31 PDT 2012


Eric Seidel <eric at webkit.org> has granted Luke Macpherson
<macpherson at chromium.org>'s request for review:
Bug 81492: Use CSSPrimitiveValue::convertToLength() in a few places.
https://bugs.webkit.org/show_bug.cgi?id=81492

Attachment 132546: Patch
https://bugs.webkit.org/attachment.cgi?id=132546&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=132546&action=review


OK.  These template functions seem slightly awkward to use.  I could easily
imagine missing one of the OR bits I should have when writing new code. :(

> Source/WebCore/css/CSSStyleApplyProperty.cpp:1568
> +	  
selector->style()->setVerticalAlignLength(primitiveValue->convertToLength<Fixed
IntegerConversion | PercentConversion>(selector->style(),
selector->rootElementStyle(), selector->style()->effectiveZoom()));

I think having a Length local might help readability here. :)


More information about the webkit-reviews mailing list