[webkit-reviews] review granted: [Bug 81446] Cache the type string of JavaScript object : [Attachment 132769] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 20 09:37:25 PDT 2012


Geoffrey Garen <ggaren at apple.com> has granted Benjamin Poulain
<benjamin at webkit.org>'s request for review:
Bug 81446: Cache the type string of JavaScript object
https://bugs.webkit.org/show_bug.cgi?id=81446

Attachment 132769: Patch
https://bugs.webkit.org/attachment.cgi?id=132769&action=review

------- Additional Comments from Geoffrey Garen <ggaren at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=132769&action=review


r=me

Hate to leave 1.7% on the table, but I do prefer the approach here for memory
reasons, and the overall speedup is still quite large. I think it's reasonable
to take the speedup and move on.

>> Source/JavaScriptCore/runtime/SmallStrings.h:81
>> +	    JSString* name##Keyword(JSGlobalData* globalData) const \
> 
> I suffixed with "Keyword" to avoid name clash with the C++ keywords.
> I considered the suffix "String", but "nullString" is too ambiguous in my
opinion.
> 
> Any suggestion for a better name is welcome.

I'd prefer "name##String" because not all of these strings are, in fact,
keywords.


More information about the webkit-reviews mailing list