[webkit-reviews] review granted: [Bug 81575] WTR - log the pid of a crashing WebProcess : [Attachment 132692] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 19 20:41:52 PDT 2012


Alexey Proskuryakov <ap at webkit.org> has granted Dirk Pranke
<dpranke at chromium.org>'s request for review:
Bug 81575: WTR - log the pid of a crashing WebProcess
https://bugs.webkit.org/show_bug.cgi?id=81575

Attachment 132692: Patch
https://bugs.webkit.org/attachment.cgi?id=132692&action=review

------- Additional Comments from Alexey Proskuryakov <ap at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=132692&action=review


> This patch is almost certainly not the right way to fix this

Is your concern only about the style of include? It's wrong indeed, suggestion
below. I don't see anything else that would stand out as wrong here.

> Do we want to make this a generic function, since presumably we need the same
functionality on the other ports?

It's best to factor out a universal solution when there is practical need for
it. Otherwise, we risk creating a wrong design, or just over-engineering
things.

> Tools/WebKitTestRunner/TestController.cpp:43
> +#include "../../Source/WebKit2/UIProcess/API/C/mac/WKPagePrivateMac.h"

I think that this should work:

#include <WebKit2/WKPagePrivateMac.h>

> Tools/WebKitTestRunner/TestController.cpp:497
> -    if (!resetStateToConsistentValues()) {
> +	if (!resetStateToConsistentValues()) {

Wrong indentation.

> Tools/WebKitTestRunner/TestController.cpp:499
> +	   int pid = WKPageGetProcessIdentifier(m_mainWebView->page());

This function returns pid_t, which is a platform dependent type. I'd use this
type for the variable, and cast to long inside printf.

> Tools/WebKitTestRunner/TestController.cpp:814
> +	   int pid = WKPageGetProcessIdentifier(m_mainWebView->page());

Same comment about return type.


More information about the webkit-reviews mailing list