[webkit-reviews] review granted: [Bug 81546] [chromium] Use floating point scroll deltas for layers : [Attachment 132645] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 19 13:44:33 PDT 2012


James Robinson <jamesr at chromium.org> has granted Sami Kyostila
<skyostil at google.com>'s request for review:
Bug 81546: [chromium] Use floating point scroll deltas for layers
https://bugs.webkit.org/show_bug.cgi?id=81546

Attachment 132645: Patch
https://bugs.webkit.org/attachment.cgi?id=132645&action=review

------- Additional Comments from James Robinson <jamesr at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=132645&action=review


Looks good, just one quibble about size/point distinction

> Source/WebCore/platform/graphics/FloatPoint.h:244
> +inline FloatSize toSize(const FloatPoint& a)

i don't think you need this - looks like flooredIntSize() will give you what
you want

> Source/WebCore/platform/graphics/chromium/cc/CCLayerTreeHostImpl.cpp:156
> +    IntSize scrollTotal =
toSize(flooredIntPoint(m_scrollLayerImpl->scrollPosition() +
m_scrollLayerImpl->scrollDelta()));

flooredIntSize() ?

Alternately, should scrollTotal be an IntPoint ?

> Source/WebCore/platform/graphics/chromium/cc/CCLayerTreeHostImpl.cpp:735
> +    scroll.scrollDelta =
toSize(flooredIntPoint(m_scrollLayerImpl->scrollDelta()));

There's also a flooredIntSize(), should we just be using that instead?

I think that scrollDelta should be a IntSize, since it's representing an offset
and not an absolute coordinate


More information about the webkit-reviews mailing list