[webkit-reviews] review denied: [Bug 81341] [chromium] MediaStream API (JSEP): Introducing WebMediaHints and WebIceOptions : [Attachment 132280] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 16 13:29:57 PDT 2012


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied Tommy Widenflycht
<tommyw at google.com>'s request for review:
Bug 81341: [chromium] MediaStream API (JSEP): Introducing WebMediaHints and
WebIceOptions
https://bugs.webkit.org/show_bug.cgi?id=81341

Attachment 132280: Patch
https://bugs.webkit.org/attachment.cgi?id=132280&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=132280&action=review


> Source/WebKit/chromium/public/platform/WebIceOptions.h:46
> +class WebIceOptions {

"Ice" -> ICE

see style guide

> Source/WebKit/chromium/public/platform/WebIceOptions.h:48
> +    enum WebUseCandidatesOption {

nit: inner enums should not be "Web" prefixed

> Source/WebKit/chromium/public/platform/WebIceOptions.h:50
> +	   NO_RELAY,

nit: use WebKit CamelCase style naming.

nit: for webkit API, name enums like so:

  enum Foo {
      FooBar,
      FooBaz
  };

I'm lacking ICE familiarity, but I find the name of the enum very confusing.
What does UseCandidatesOption mean?

> Source/WebKit/chromium/public/platform/WebIceOptions.h:68
> +    WebUseCandidatesOption useCandidates() const;

need to export this one?

nit: i'm confused by the name of this function.  "useCandidates" sounds like a
command, yet
this is a const method that returns an enum value.  confusing.	is there a
better name?

> Source/WebKit/chromium/public/platform/WebMediaHints.h:62
> +    bool audio() const;

nit: export methods?


More information about the webkit-reviews mailing list