[webkit-reviews] review granted: [Bug 81268] Out-of-document radio buttons should be grouped when associated with a form : [Attachment 132125] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 16 00:01:50 PDT 2012


Kent Tamura <tkent at chromium.org> has granted Adam Klein <adamk at chromium.org>'s
request for review:
Bug 81268: Out-of-document radio buttons should be grouped when associated with
a form
https://bugs.webkit.org/show_bug.cgi?id=81268

Attachment 132125: Patch
https://bugs.webkit.org/attachment.cgi?id=132125&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=132125&action=review


> Source/WebCore/ChangeLog:65
> +	   * dom/CheckedRadioButtons.cpp:
> +	   (WebCore):
> +	   (WebCore::CheckedRadioButtons::addButton):
> +	   (WebCore::CheckedRadioButtons::updateCheckedState):
> +	   (WebCore::CheckedRadioButtons::requiredAttributeChanged):
> +	   (WebCore::CheckedRadioButtons::isRequiredGroup):
> +	   (WebCore::CheckedRadioButtons::removeButton):
> +	   * dom/CheckedRadioButtons.h:
> +	   (CheckedRadioButtons):
> +	   * html/HTMLInputElement.cpp:
> +	   (WebCore::HTMLInputElement::~HTMLInputElement):
> +	   (WebCore::HTMLInputElement::updateType):
> +	   (WebCore::HTMLInputElement::parseAttribute):
> +	   (WebCore::HTMLInputElement::setChecked):
> +	   (WebCore::HTMLInputElement::willChangeForm):
> +	   (WebCore::HTMLInputElement::didChangeForm):
> +	   (WebCore::HTMLInputElement::insertedIntoDocument):
> +	   (WebCore::HTMLInputElement::removedFromDocument):
> +	   (WebCore::HTMLInputElement::didMoveToNewDocument):
> +	   (WebCore::HTMLInputElement::requiredAttributeChanged):
> +	   (WebCore::HTMLInputElement::isInRequiredRadioButtonGroup):
> +	   (WebCore):
> +	   (WebCore::HTMLInputElement::checkedRadioButtonForGroup):
> +	   (WebCore::HTMLInputElement::checkedRadioButtons):
> +	   (WebCore::HTMLInputElement::addRadioButton):
> +	   (WebCore::HTMLInputElement::removeRadioButton):
> +	   * html/HTMLInputElement.h:
> +	   (HTMLInputElement):
> +	   * html/RadioInputType.cpp:
> +	   (WebCore::RadioInputType::valueMissing):
> +	   (WebCore::RadioInputType::isKeyboardFocusable):
> +	   (WebCore::RadioInputType::willDispatchClick):

You had better add what is changed for each files/functions.

> Source/WebCore/html/HTMLInputElement.h:345
> +    void addRadioButton();
> +    void removeRadioButton();

I'd like to name them:
  addToRadioButtonGroup()
  removeFromRadioButtonGroup()


More information about the webkit-reviews mailing list