[webkit-reviews] review granted: [Bug 80970] File upload control should use File.name() rather than File.path() to show chosen filenames : [Attachment 131564] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 13 00:37:26 PDT 2012


Kent Tamura <tkent at chromium.org> has granted Kinuko Yasuda
<kinuko at chromium.org>'s request for review:
Bug 80970: File upload control should use File.name() rather than File.path()
to show chosen filenames
https://bugs.webkit.org/show_bug.cgi?id=80970

Attachment 131564: Patch
https://bugs.webkit.org/attachment.cgi?id=131564&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=131564&action=review


> Source/WebCore/ChangeLog:3
> +	   [chromium] File upload control should use File.name() rather than
File.path() to show chosen filenames

Please do not prepend [Chrmoum] for a patch updating non-Chromium part.

> Source/WebCore/rendering/RenderTheme.h:219
> -    virtual String fileListNameForWidth(const Vector<String>& filenames,
const Font&, int width, bool multipleFilesAllowed) const;
> +    virtual String fileListNameForWidth(FileList*, const Font&, int width,
bool multipleFilesAllowed) const;

nit: FileList* can be const?


More information about the webkit-reviews mailing list