[webkit-reviews] review denied: [Bug 80970] File upload control should use File.name() rather than File.path() to show chosen filenames : [Attachment 131561] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 13 00:22:44 PDT 2012


Kent Tamura <tkent at chromium.org> has denied Kinuko Yasuda
<kinuko at chromium.org>'s request for review:
Bug 80970: File upload control should use File.name() rather than File.path()
to show chosen filenames
https://bugs.webkit.org/show_bug.cgi?id=80970

Attachment 131561: Patch
https://bugs.webkit.org/attachment.cgi?id=131561&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=131561&action=review


> Source/WebCore/rendering/RenderTheme.h:219
> -    virtual String fileListNameForWidth(const Vector<String>& filenames,
const Font&, int width, bool multipleFilesAllowed) const;
> +    virtual String fileListNameForWidth(PassRefPtr<FileList>, const Font&,
int width, bool multipleFilesAllowed) const;

Using PassRefPtr<> is not appropriate because we don't need to move reference
count ownership from the caller to fileListNameForWidth.
FileList* is enough.


More information about the webkit-reviews mailing list