[webkit-reviews] review denied: [Bug 80970] File upload control should use File.name() rather than File.path() to show chosen filenames : [Attachment 131550] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 12 23:31:29 PDT 2012


Kent Tamura <tkent at chromium.org> has denied Kinuko Yasuda
<kinuko at chromium.org>'s request for review:
Bug 80970: File upload control should use File.name() rather than File.path()
to show chosen filenames
https://bugs.webkit.org/show_bug.cgi?id=80970

Attachment 131550: Patch
https://bugs.webkit.org/attachment.cgi?id=131550&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=131550&action=review


> Source/WebCore/rendering/RenderFileUploadControl.cpp:239
> -    return theme()->fileListNameForWidth(input->files()->paths(),
style()->font(), maxFilenameWidth(), input->multiple());
> +    return theme()->fileListNameForWidth(input->files()->names(),
style()->font(), maxFilenameWidth(), input->multiple());

I think this is not a compatible change.
RenderThemeMac.mm uses NSFileMaanger::displayNameAtPath to make a user-visible
string. It requires a full path name.

How about passing a FileList to fileListNameForWidth() instead of a Vector of
paths?


More information about the webkit-reviews mailing list