[webkit-reviews] review granted: [Bug 80462] [V8] Add DEFINE_STATIC_HIDDEN_PROPERTY() macro and use it in CodeGeneratorV8.pm : [Attachment 130535] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 6 22:19:22 PST 2012


Adam Barth <abarth at webkit.org> has granted Kentaro Hara
<haraken at chromium.org>'s request for review:
Bug 80462: [V8] Add DEFINE_STATIC_HIDDEN_PROPERTY() macro and use it in
CodeGeneratorV8.pm
https://bugs.webkit.org/show_bug.cgi?id=80462

Attachment 130535: Patch
https://bugs.webkit.org/attachment.cgi?id=130535&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=130535&action=review


> Source/WebCore/bindings/v8/custom/V8BindingMacros.h:57
> +#define DEFINE_STATIC_HIDDEN_PROPERTY(name) \
> +    DEFINE_STATIC_LOCAL(v8::Persistent<v8::String>, name,
(v8::Persistent<v8::String>::New(v8::String::NewSymbol(#name
"::HiddenProperty"))));

Can we stick with using a prefix (rather than a suffix)?  Also, we probably
want to include "WebCore" somewhere in the prefix.

For context, the problem is that the hidden property names exist in a common
namespace.  There's other code that pokes at hidden properties (e.g., the
extension system), so we want to make sure we're using distinct names.


More information about the webkit-reviews mailing list