[webkit-reviews] review granted: [Bug 80164] [Qt] QWebNavigationRequest 'action' property should have an enum type instead of int : [Attachment 130167] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 6 10:09:04 PST 2012


Simon Hausmann <hausmann at webkit.org> has granted Caio Marcelo de Oliveira Filho
<cmarcelo at webkit.org>'s request for review:
Bug 80164: [Qt] QWebNavigationRequest 'action' property should have an enum
type instead of int
https://bugs.webkit.org/show_bug.cgi?id=80164

Attachment 130167: Patch
https://bugs.webkit.org/attachment.cgi?id=130167&action=review

------- Additional Comments from Simon Hausmann <hausmann at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=130167&action=review


> Source/WebKit2/UIProcess/API/qt/qquickwebview_p.h:86
> +	   IgnoreRequest = 0xFF

Why not simply leave it as its original value and use DownloadRequest =
IgnoreRequest + 1?
It seems strange to have a gap in the _existing_ enums.

or

   enum NavigationRequestAction {
       AcceptRequest,
       IgnoreRequest,
       LastRequestAction = IgnoreRequest /* Mark internal in docs! */
   }

    DownloadRequest = LastRequest

I recall seeing the pattern like this in Qt. (see qnamespace.h)


More information about the webkit-reviews mailing list