[webkit-reviews] review granted: [Bug 80024] Web Inspector: [Styles] [CRASH] Handle rule addition and inline style editing failure due to Content-Security-Policy in the page : [Attachment 129903] [PATCH] Comments addressed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 2 09:11:03 PST 2012


Pavel Feldman <pfeldman at chromium.org> has granted Alexander Pavlov (apavlov)
<apavlov at chromium.org>'s request for review:
Bug 80024: Web Inspector: [Styles] [CRASH] Handle rule addition and inline
style editing failure due to Content-Security-Policy in the page
https://bugs.webkit.org/show_bug.cgi?id=80024

Attachment 129903: [PATCH] Comments addressed
https://bugs.webkit.org/attachment.cgi?id=129903&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=129903&action=review


> Source/WebCore/inspector/InspectorCSSAgent.cpp:745
> +	   *errorString = "Failed to find or create inspector stylesheet,
probably due to Content-Security-Policy";

This is no longer the case.

> Source/WebCore/inspector/InspectorStyleSheet.cpp:1324
> +    ContentSecurityPolicy* policy = m_element->ownerDocument() ?
m_element->ownerDocument()->contentSecurityPolicy() : 0;

ownerDocument never returns NULL for an element. Also, I would recommend using
raii idiom for this case.

> Source/WebCore/page/ContentSecurityPolicy.h:73
> +    void setOverrideAllowInlineStyle(bool);

Do we need a better name for this method?
setOverrideAllowInlineStyleForInspector ?


More information about the webkit-reviews mailing list