[webkit-reviews] review requested: [Bug 89439] [Forms] Make step action of SpinButtonElement replaceable : [Attachment 148480] Patch 3

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 19 18:52:51 PDT 2012


yosin at chromium.org has asked  for review:
Bug 89439: [Forms] Make step action of SpinButtonElement replaceable
https://bugs.webkit.org/show_bug.cgi?id=89439

Attachment 148480: Patch 3
https://bugs.webkit.org/attachment.cgi?id=148480&action=review

------- Additional Comments from yosin at chromium.org
Could you review this patch?
Thanks in advance.

* I would like to use separate methods for Step Up and Step Down. Because, 
** it isn't Intuitive that stepUp(-1)==stepDown(1)
** We don't want to check parameter isn't zero and to have ASSERT(n).
** I guess if we have stepUpFromRenderer and stepDownFromRenderer, it code
could be simpler.

= Changes since last patch =
* Rename SpinButtonElement::Callback to StepActionHandler
* SpinButtonElement keeps m_stepActionHandler as pointer and checks it isn't
nullptr before calling action.
* Add SpinButtonElement::removeStepActionHandler
** This method will be called from TextFieldInputType dtor and
destroyShadowSubtree
* Add virtual destructor to StepButtonElement for Mac-clang
* Move InputType::stepUpFromRenderer to TextFieldInputType
* Expose InputType::applyStep as protected for stepUpFromRenderer


More information about the webkit-reviews mailing list