[webkit-reviews] review denied: [Bug 89293] [TextureMapper] Reduce boilerplate code in the TextureMapperShaderManager : [Attachment 148044] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sun Jun 17 21:36:51 PDT 2012
Noam Rosenthal <noam.rosenthal at nokia.com> has denied Martin Robinson
<mrobinson at webkit.org>'s request for review:
Bug 89293: [TextureMapper] Reduce boilerplate code in the
TextureMapperShaderManager
https://bugs.webkit.org/show_bug.cgi?id=89293
Attachment 148044: Patch
https://bugs.webkit.org/attachment.cgi?id=148044&action=review
------- Additional Comments from Noam Rosenthal <noam.rosenthal at nokia.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=148044&action=review
Awesome!
Though let's use >= 0 or an enum { InvalidLocation = -1 } instead of using -1
as a magic number.
> Source/WebCore/platform/graphics/texmap/TextureMapperGL.cpp:397
> + if (program->opacityLocation() != -1)
How about >= 0
> Source/WebCore/platform/graphics/texmap/TextureMapperGL.cpp:434
> + if (program->opacityLocation() != -1)
>= 0
More information about the webkit-reviews
mailing list