[webkit-reviews] review granted: [Bug 78111] Add unprefixed Blob.webkitSlice (slice) : [Attachment 147024] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jun 12 21:08:51 PDT 2012
Adam Barth <abarth at webkit.org> has granted Kinuko Yasuda
<kinuko at chromium.org>'s request for review:
Bug 78111: Add unprefixed Blob.webkitSlice (slice)
https://bugs.webkit.org/show_bug.cgi?id=78111
Attachment 147024: Patch
https://bugs.webkit.org/attachment.cgi?id=147024&action=review
------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=147024&action=review
> Source/WebCore/bindings/gobject/WebKitDOMCustom.h:32
> -WEBKIT_API WebKitDOMBlob* webkit_dom_blob_slice(WebKitDOMBlob* self, gint64
start, gint64 end, const gchar* content_type);
> +WEBKIT_API WebKitDOMBlob* webkit_dom_blob_webkit_slice(WebKitDOMBlob* self,
gint64 start, gint64 end, const gchar* content_type);
Why the addition of "webkit" here? I would have thought we'd be happy with
fewer webkits, not more.
> Source/WebCore/fileapi/Blob.cpp:97
> + String message("Blob.webkitSlice() is deprecated. Use Blob.slice()
instead .");
Looks like you've got an extra space before the .
> Source/WebCore/fileapi/Blob.h:75
> + // Prefixed version is going to be deprecated. This internally calls
sliceInternal() (as slice() does) after showing a deprecation message.
"is going to be deprecated" => "is deprecated" :)
More information about the webkit-reviews
mailing list