[webkit-reviews] review denied: [Bug 87965] Need customized toDOMStringList for IndexedDB JSC binding. : [Attachment 146992] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 11 19:12:06 PDT 2012


Kentaro Hara <haraken at chromium.org> has denied Charles Wei
<charles.wei at torchmobile.com.cn>'s request for review:
Bug 87965: Need customized toDOMStringList for IndexedDB JSC binding.
https://bugs.webkit.org/show_bug.cgi?id=87965

Attachment 146992: Patch
https://bugs.webkit.org/attachment.cgi?id=146992&action=review

------- Additional Comments from Kentaro Hara <haraken at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=146992&action=review


> Source/WebCore/ChangeLog:10
> +	   The generated toDOMStringList() can't convert an JSArry of Strings
to 
> +	   native DOMStringList. We need a custom function to do this.

We do not want to add custom bindings. Instead you can add toDOMStringList() to
JSDOMBinding.{h,cpp}. Please refer to v8ValueToWebCoreDOMStringList() in
V8Binding.{h,cpp}

Also valueToDOMStringList() would be a better name, for consistency with other
names in JSDOMBinding.h.

> Source/WebCore/bindings/js/JSDOMStringListCustom.cpp:34
> +    for (int i = 0; i < array->length(); ++i)

Nit: int => unsigned


More information about the webkit-reviews mailing list