[webkit-reviews] review requested: [Bug 83877] [GTK][WK2] Implement geolocation provider for the GTK port : [Attachment 145579] Patch proposal

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 4 07:14:18 PDT 2012


Mario Sanchez Prada <msanchez at igalia.com> has asked  for review:
Bug 83877: [GTK][WK2] Implement geolocation provider for the GTK port
https://bugs.webkit.org/show_bug.cgi?id=83877

Attachment 145579: Patch proposal
https://bugs.webkit.org/attachment.cgi?id=145579&action=review

------- Additional Comments from Mario Sanchez Prada <msanchez at igalia.com>
(In reply to comment #31)
> (From update of attachment 145569 [details])
> View in context:
https://bugs.webkit.org/attachment.cgi?id=145569&action=review
> 
> You need to add WebKitGeolocationProvider to the list fo files ignored by
gtk-doc, or rename it to WebKitGeolocationClient, since *Client is ignored

Fixed. Sorry.

> > Source/WebKit2/UIProcess/API/gtk/WebKitGeolocationProvider.cpp:34
> > +	 const WebKitGeolocationProvider* providerClientInfo =
static_cast<const WebKitGeolocationProvider*>(clientInfo);
> > +	 return const_cast<WebKitGeolocationProvider*>(providerClientInfo);
> 
> I think this could be just return
static_cast<WebKitGeolocationProvider*>(const_cast<void*>(clientInfo));

You're right. Fixed too


More information about the webkit-reviews mailing list