[webkit-reviews] review denied: [Bug 87644] Web Inspector: Option for selecting/deselecting all breakpoints in breakpoint pane : [Attachment 145516] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 4 05:22:41 PDT 2012


Pavel Feldman <pfeldman at chromium.org> has denied sam <dsam2912 at gmail.com>'s
request for review:
Bug 87644: Web Inspector: Option for selecting/deselecting all breakpoints in
breakpoint pane
https://bugs.webkit.org/show_bug.cgi?id=87644

Attachment 145516: Patch
https://bugs.webkit.org/attachment.cgi?id=145516&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=145516&action=review


localizedStrings is no longer binary. please edit it as a text file with UTF-8
encoding, this bug should show a nice diff in the file.

> Source/WebCore/inspector/front-end/BreakpointManager.js:141
> +    selectAllBreakpoints: function()

This name is misleading: should be enableAllBreakpoints.

> Source/WebCore/inspector/front-end/BreakpointManager.js:152
> +	   for (var i = 0; i < this._breakpoints.length; ++i) {

ditto (disable)

> Source/WebCore/inspector/front-end/BreakpointsSidebarPane.js:178
> +	   function selectedBreakpointsCount(breakpoints)

enabledBreakpointCount

> Source/WebCore/inspector/front-end/BreakpointsSidebarPane.js:192
> +		   contextMenu.appendItem(WebInspector.UIString("Select All
Breakpoints"),
this._breakpointManager.selectAllBreakpoints.bind(this._breakpointManager));

Enable / disable. also, you should capitalize breakpoints depending on the
useLowerCaseMenuTitles.


More information about the webkit-reviews mailing list