[webkit-reviews] review granted: [Bug 92689] Remove overflow: scroll handling in block flow layout methods : [Attachment 155391] Proposed refactoring: move the code to updateScrollbarsAfterStyleChange, add list box part handling and remove duplicated code.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 30 16:33:12 PDT 2012


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Julien Chaffraix
<jchaffraix at webkit.org>'s request for review:
Bug 92689: Remove overflow: scroll handling in block flow layout methods
https://bugs.webkit.org/show_bug.cgi?id=92689

Attachment 155391: Proposed refactoring: move the code to
updateScrollbarsAfterStyleChange, add list box part handling and remove
duplicated code.
https://bugs.webkit.org/attachment.cgi?id=155391&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=155391&action=review


> Source/WebCore/rendering/RenderLayer.cpp:2530
> +    if (UNLIKELY(box->style()->appearance() == ListboxPart))

I don't think UNLIKELY is useful here.

> Source/WebCore/rendering/RenderLayer.cpp:4847
> +    if (UNLIKELY(box->style()->appearance() == ListboxPart))

Ditto.

> Source/WebCore/rendering/RenderLayer.cpp:4856
> +    if (!overflowCanHaveAScrollbar(overflowX))
>	   setHasHorizontalScrollbar(false);
> -    if (hasVerticalScrollbar() && !overflowCanHaveAScrollbar(overflowY))
> +    else if (overflowRequiresAScrollbar(overflowX))
> +	   setHasHorizontalScrollbar(true);

Having this if/else is confusing, since overflowCanHaveAScrollbar and
overflowRequiresAScrollbar both consult the same EOverflow value.


More information about the webkit-reviews mailing list