[webkit-reviews] review denied: [Bug 92519] Plugins should not be allowed to override standard properties/attributes in non-standard worlds : [Attachment 155038] Patch v3 - Don't touch the bindings script. Much better!

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 27 13:28:36 PDT 2012


Anders Carlsson <andersca at apple.com> has denied Brady Eidson
<beidson at apple.com>'s request for review:
Bug 92519: Plugins should not be allowed to override standard
properties/attributes in non-standard worlds
https://bugs.webkit.org/show_bug.cgi?id=92519

Attachment 155038: Patch v3 - Don't touch the bindings script.	Much better!
https://bugs.webkit.org/attachment.cgi?id=155038&action=review

------- Additional Comments from Anders Carlsson <andersca at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=155038&action=review


> Source/WebCore/bindings/js/JSHTMLAppletElementCustom.cpp:46
> +    if (!globalObject()->world()->isNormal()) {
> +	   if (getStaticValueSlot<JSHTMLAppletElement, Base>(exec,
s_info.staticPropHashTable, this, propertyName, slot))
> +	       return true;
> +
> +	   JSValue proto = prototype();
> +	   if (proto.isObject() &&
jsCast<JSObject*>(asObject(proto))->hasProperty(exec, propertyName))
> +	       return false;
> +    }
> +

I think you should factor this code out into a function template and put it in
JSPluginElementFunctions.h

>
Tools/DumpRenderTree/TestNetscapePlugIn/Tests/PluginScriptableObjectOverridesAl
lProperties.cpp:60
> +	       int stringLength = strlen(propertyString) + strlen(message) + 1;


I'd call this bufferLenght instead of stringLength.


More information about the webkit-reviews mailing list