[webkit-reviews] review denied: [Bug 92342] Web Inspector [JSC]: Support multi instance for PageScriptDebugServer of JSC : [Attachment 154609] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 26 05:50:53 PDT 2012


Yury Semikhatsky <yurys at chromium.org> has denied Peter Wang
<peter.wang at torchmobile.com.cn>'s request for review:
Bug 92342: Web Inspector [JSC]: Support multi instance for
PageScriptDebugServer of JSC
https://bugs.webkit.org/show_bug.cgi?id=92342

Attachment 154609: Patch
https://bugs.webkit.org/attachment.cgi?id=154609&action=review

------- Additional Comments from Yury Semikhatsky <yurys at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=154609&action=review


> Source/WebCore/bindings/js/PageScriptDebugServer.cpp:68
> +    if (!page)

How can it happen?

> Source/WebCore/bindings/js/PageScriptDebugServer.cpp:86
> +    m_pageDebugServerMap.add(page, serverForPage);

Pleas move this line into PageScriptDebugServer constructor.

> Source/WebCore/bindings/js/PageScriptDebugServer.cpp:198
> +    deleteInstance(page);

I'd replace this with delete this; and get rid of
PageScriptDebugServer::deleteInstance

> Source/WebCore/bindings/v8/PageScriptDebugServer.cpp:67
> +PageScriptDebugServer& PageScriptDebugServer::shared(Page*)

Please rename this method to something like forPage as now there is no shared
instance.

> Source/WebCore/inspector/PageDebuggerAgent.cpp:72
> +    if (PageScriptDebugServer::isMultiInstance())

No need in this check just ignore the Page* argument in case of v8 and delete
isMultiInstance.


More information about the webkit-reviews mailing list