[webkit-reviews] review denied: [Bug 92230] [Forms] Move HTMLInputElement::updateInnerTextValue to InputType class : [Attachment 154295] Patch 1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 25 02:31:21 PDT 2012


Kent Tamura <tkent at chromium.org> has denied yosin at chromium.org's request for
review:
Bug 92230: [Forms] Move HTMLInputElement::updateInnerTextValue to InputType
class
https://bugs.webkit.org/show_bug.cgi?id=92230

Attachment 154295: Patch 1
https://bugs.webkit.org/attachment.cgi?id=154295&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=154295&action=review


> Source/WebCore/html/HTMLInputElement.cpp:493
>  void HTMLInputElement::updateInnerTextValue()
>  {

Please remove HTMLInputElement::updateInnerTextValue().

> Source/WebCore/html/InputType.h:262
> +    virtual void updateInnerValue() { }

Do not define function body in a header for virtual functions.	It wastes build
time.

> Source/WebCore/html/TextFieldInputType.cpp:453
> +void TextFieldInputType::updateInnerValue()

The function name should be updateInnerTextValue() because of consistency with
'innerText' functions though I don't like this name.


More information about the webkit-reviews mailing list