[webkit-reviews] review denied: [Bug 91630] Web Inspector: Incorrect XHR responses when two async xhrs are sent synchronously : [Attachment 153523] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 24 08:24:48 PDT 2012


Vsevolod Vlasov <vsevik at chromium.org> has denied Pavel Chadnov
<chadnov at google.com>'s request for review:
Bug 91630: Web Inspector: Incorrect XHR responses when two async xhrs are sent
synchronously
https://bugs.webkit.org/show_bug.cgi?id=91630

Attachment 153523: Patch
https://bugs.webkit.org/attachment.cgi?id=153523&action=review

------- Additional Comments from Vsevolod Vlasov <vsevik at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=153523&action=review


Please fix style nits and add ChangeLogs.

> Source/WebCore/inspector/InspectorInstrumentation.cpp:678
> +    InspectorInstrumentation::didReceiveResourceResponse(cookie, identifier,
loader, r, 0);

You don't need 0 here because you resourceLoader parameter has default value.

> Source/WebCore/inspector/InspectorResourceAgent.cpp:246
> +	   CachedResource* cachedResource = (resourceLoader &&
resourceLoader->isSubresourceLoader()) ?
reinterpret_cast<SubresourceLoader*>(resourceLoader)->cachedResource() : 
InspectorPageAgent::cachedResource(loader->frame(), response.url());

You should use static_cast instead.
Also this line is too hard to read, please use *if* instead of ?:
Also please always fallback to InspectorPageAgent::cachedResource.


More information about the webkit-reviews mailing list