[webkit-reviews] review granted: [Bug 89751] Change RenderTable sections' iterations for removing anti-patterns and using helper functions. : [Attachment 149505] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 12 14:58:51 PDT 2012


Julien Chaffraix <jchaffraix at webkit.org> has granted Arpita Bahuguna
<arpitabahuguna at gmail.com>'s request for review:
Bug 89751: Change RenderTable sections' iterations for removing anti-patterns
and using helper functions.
https://bugs.webkit.org/show_bug.cgi?id=89751

Attachment 149505: Patch
https://bugs.webkit.org/attachment.cgi?id=149505&action=review

------- Additional Comments from Julien Chaffraix <jchaffraix at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=149505&action=review


r=me without the splitColumns part.

> Source/WebCore/ChangeLog:3
> +	   Change RenderTable sections' iterations for removing anti-patterns
and using helper functions.

A better name: Refactor RenderTable to use the section's iteration functions

> Source/WebCore/ChangeLog:11
> +	   No new tests required for this change.

Usually you justify why. Here it is because you don't expect any change in
behavior.

> Source/WebCore/rendering/RenderTable.cpp:683
> +    for (RenderTableSection* section = topSection(); section; section =
sectionBelow(section)) {

You are right nothing guarantees us not to need a section recalc here.


More information about the webkit-reviews mailing list