[webkit-reviews] review granted: [Bug 77428] Tap highlighting: Support better outlines for multiline inlines : [Attachment 124714] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 31 06:07:32 PST 2012


Simon Hausmann <hausmann at webkit.org> has granted Kenneth Rohde Christiansen
<kenneth at webkit.org>'s request for review:
Bug 77428: Tap highlighting: Support better outlines for multiline inlines
https://bugs.webkit.org/show_bug.cgi?id=77428

Attachment 124714: Patch
https://bugs.webkit.org/attachment.cgi?id=124714&action=review

------- Additional Comments from Simon Hausmann <hausmann at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=124714&action=review


> Source/WebCore/page/GestureTapHighlighter.cpp:133
> +inline bool contains(LayoutRect rect, int x)

missing "static" keyword?

> Source/WebCore/page/GestureTapHighlighter.cpp:173
> +    if (!first.isEmpty()) {
> +	   addRectWithRoundedCorners(path, first,
> +		   true, true,
> +		   !contains(middle, first.x()) && !contains(last, first.x()),
> +		   !contains(middle, first.maxX()) && !contains(last,
first.maxX()));

I wish there was a way to write this more readable, i.e. make it clearer what
the meaning of the booleans here is.


More information about the webkit-reviews mailing list