[webkit-reviews] review granted: [Bug 77070] All DFG helpers that may call out to arbitrary JS code must know where they were called from due to inlining and call stack walking : [Attachment 124067] the patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 26 15:02:26 PST 2012


Geoffrey Garen <ggaren at apple.com> has granted Filip Pizlo <fpizlo at apple.com>'s
request for review:
Bug 77070: All DFG helpers that may call out to arbitrary JS code must know
where they were called from due to inlining and call stack walking
https://bugs.webkit.org/show_bug.cgi?id=77070

Attachment 124067: the patch
https://bugs.webkit.org/attachment.cgi?id=124067&action=review

------- Additional Comments from Geoffrey Garen <ggaren at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=124067&action=review


Need some Windows JavaScriptCore.def love:

3>JavaScriptCore.exp : error LNK2001: unresolved external symbol "public: class
JSC::JSValue __thiscall JSC::Interpreter::retrieveCaller(class JSC::ExecState
*,class JSC::JSFunction *)const "
(?retrieveCaller at Interpreter@JSC@@QBE?AVJSValue at 2@PAVExecState at 2@PAVJSFunction@
2@@Z)

Need to double-check that we're actually passing this test:

  fast/js/dfg-inline-arguments-use-from-all-the-places-broken.html ->
unexpected text diff mismatch

> Source/JavaScriptCore/jit/JITStubs.h:287
> +    inline bool returnAddressIsInCallTrampoline(ReturnAddressPtr
returnAddress)

Small quibble: I don't think it's right to name this the "call trampoline",
since it's used for entry to global code as well. I would call it
"returnAddressIsInCtiTrampoline", to match the C function name.


More information about the webkit-reviews mailing list