[webkit-reviews] review granted: [Bug 76975] Fix the semantics of passing contentsVisible flag to GraphicsLayers : [Attachment 123875] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 24 21:42:05 PST 2012


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Shawn Singh
<shawnsingh at chromium.org>'s request for review:
Bug 76975: Fix the semantics of passing contentsVisible flag to GraphicsLayers
https://bugs.webkit.org/show_bug.cgi?id=76975

Attachment 123875: Patch
https://bugs.webkit.org/attachment.cgi?id=123875&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=123875&action=review


> Source/WebCore/rendering/RenderLayerBacking.cpp:410
> +    m_graphicsLayer->setContentsVisible(m_owningLayer->hasVisibleContent()
|| hasVisibleNonCompositingDescendantLayers());

I think it would be better to use RenderLayer's hasVisibleDescendant() instead
of hasVisibleNonCompositingDescendantLayers(), since it's faster.


More information about the webkit-reviews mailing list