[webkit-reviews] review granted: [Bug 71820] Linecaps wrong for zero length lines : [Attachment 123745] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 24 11:20:10 PST 2012


Nikolas Zimmermann <zimmermann at kde.org> has granted Stephen Chenney
<schenney at chromium.org>'s request for review:
Bug 71820: Linecaps wrong for zero length lines
https://bugs.webkit.org/show_bug.cgi?id=71820

Attachment 123745: Patch
https://bugs.webkit.org/attachment.cgi?id=123745&action=review

------- Additional Comments from Nikolas Zimmermann <zimmermann at kde.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=123745&action=review


r=me with additional comments:

> Source/WebCore/rendering/svg/RenderSVGShape.cpp:139
> +    // FIXME: This is not correct for round linecaps

Missing period. I'd prefer if you'd link to a bug report here, can you fix that
before landing?

> Source/WebCore/rendering/svg/RenderSVGShape.cpp:432
> +    for (size_t i = 0; i < m_zeroLengthLinecapLocations.size(); ++i) {

No need for the braces, they should be removed.

> Source/WebCore/rendering/svg/RenderSVGSubpathData.h:29
> +class RenderSVGSubpathData {

Oh, this should be named SVGSubpathData, or SVGZeroLengthSubpathHandler, but no
Render* prefix. For SVG, everything starting with Render is a RenderObject
dervied object. Stuff like SVGMarkerData, etc. is not.


More information about the webkit-reviews mailing list