[webkit-reviews] review granted: [Bug 76737] Allow delayed DC allocation in HWndDC. : [Attachment 123375] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 23 08:38:42 PST 2012


Adam Roben (:aroben) <aroben at apple.com> has granted David Levin
<levin at chromium.org>'s request for review:
Bug 76737: Allow delayed DC allocation in HWndDC.
https://bugs.webkit.org/show_bug.cgi?id=76737

Attachment 123375: Patch
https://bugs.webkit.org/attachment.cgi?id=123375&action=review

------- Additional Comments from Adam Roben (:aroben) <aroben at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=123375&action=review


> Source/WebCore/platform/win/HWndDC.h:37
> +    explicit HWndDC()

"explicit" is only needed for constructs that have one (and only one) required
parameter.

> Source/WebCore/platform/win/HWndDC.h:60
> +    HDC changeWindowDC(HWND hwnd)

"changeWindowDC" sounds like a function that takes an HDC, not an HWND. Maybe
"setHwnd" would be a clearer name?

> Source/WebCore/platform/win/HWndDC.h:68
> +    void clearDC()

I think this could just be called "clear". It would be nice if "myHwndDC =
nullptr" did the same thing as "myHwndDC.clear()", to match classes like RefPtr
and OwnPtr.


More information about the webkit-reviews mailing list