[webkit-reviews] review granted: [Bug 76783] [GTK] Refactor GTK's accessibilitity code to be more modular : [Attachment 123478] 5. New files for the implementation of the AtkAction interface

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jan 22 09:09:36 PST 2012


Martin Robinson <mrobinson at webkit.org> has granted Mario Sanchez Prada
<msanchez at igalia.com>'s request for review:
Bug 76783: [GTK] Refactor GTK's accessibilitity code to be more modular
https://bugs.webkit.org/show_bug.cgi?id=76783

Attachment 123478: 5. New files for the implementation of the AtkAction
interface
https://bugs.webkit.org/attachment.cgi?id=123478&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=123478&action=review


Please fix the issues below.

> Source/WebCore/accessibility/gtk/WebKitAccessibleInterfaceAction.h:41
> +G_BEGIN_DECLS
> +
> +void webkitAccessibleActionInterfaceInit(AtkActionIface*);
> +
> +gboolean webkitAccessibleActionDoAction(AtkAction*, gint index);
> +
> +gint webkitAccessibleActionGetNActions(AtkAction*);
> +
> +const gchar* webkitAccessibleActionGetDescription(AtkAction*, gint index);
> +
> +const gchar* webkitAccessibleActionGetKeybinding(AtkAction*, gint index);
> +
> +const gchar* webkitAccessibleActionGetName(AtkAction*, gint index);
> +
> +G_END_DECLS

No need to put B_BEGIN_DECLS/G_END_DECLS. I don't think we usually separate
function declarations by newlines like this.

> Source/WebCore/accessibility/gtk/WebKitAccessibleWrapperAtk.cpp:2436
> +    {(GInterfaceInitFunc)webkitAccessibleActionInterfaceInit,

You should use a static cast here since you're rewriting the line.


More information about the webkit-reviews mailing list