[webkit-reviews] review granted: [Bug 76458] SpaceSplitString: Share equivalent string piece vectors. : [Attachment 122791] Patch v2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 17 12:01:35 PST 2012


Antti Koivisto <koivisto at iki.fi> has granted Andreas Kling <kling at webkit.org>'s
request for review:
Bug 76458: SpaceSplitString: Share equivalent string piece vectors.
https://bugs.webkit.org/show_bug.cgi?id=76458

Attachment 122791: Patch v2
https://bugs.webkit.org/attachment.cgi?id=122791&action=review

------- Additional Comments from Antti Koivisto <koivisto at iki.fi>
View in context: https://bugs.webkit.org/attachment.cgi?id=122791&action=review


looks good, r=me

> Source/WebCore/dom/SpaceSplitString.cpp:161
> +PassRefPtr<SpaceSplitStringData> SpaceSplitStringData::create(const
SpaceSplitStringData& other)

Maybe createUnique() or similar?

> Source/WebCore/dom/SpaceSplitString.cpp:178
> +    // Note that we don't copy m_string to indicate to the destructor that
there's nothing
> +    // to be removed from the sharedDataMap().

You might want to rename m_string to m_stringKey or similar to indicate its
purpose.


More information about the webkit-reviews mailing list