[webkit-reviews] review granted: [Bug 73773] [WK2][GTK] WebSettings support in MiniBrowser : [Attachment 120887] WebSettings support in MiniBrowser

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 2 10:16:47 PST 2012


Martin Robinson <mrobinson at webkit.org> has granted Philippe Normand
<pnormand at igalia.com>'s request for review:
Bug 73773: [WK2][GTK] WebSettings support in MiniBrowser
https://bugs.webkit.org/show_bug.cgi?id=73773

Attachment 120887: WebSettings support in MiniBrowser
https://bugs.webkit.org/attachment.cgi?id=120887&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=120887&action=review


Looks good, but please consider the following cleanup before landing...

> Tools/MiniBrowser/gtk/main.c:30
>  #include <webkit2/webkit2.h>

I know it was wrong before, but do you mind making sure that this is in
alphabetical order now?

> Tools/MiniBrowser/gtk/main.c:45
> +static void loadURI(const gchar *uri, WebKitSettings *webkitSettings)

Please rename this to something like createBrowserWindow.

> Tools/MiniBrowser/gtk/main.c:88
> +	   gboolean propertyValue = TRUE;
> +	   if (value && g_ascii_strcasecmp(value, "true") && strcmp(value,
"1"))
> +	       propertyValue = FALSE;

This can just be: 

gboolean propertyValue = !(value && g_ascii_strcasecmp(value, "true") &&
strcmp(value, "1"));


More information about the webkit-reviews mailing list