[webkit-reviews] review denied: [Bug 79521] [Qt][WK2] Use movementStarted/Ended signals instead of movingChanged on QtViewportInterationEngine : [Attachment 128787] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Feb 25 05:13:49 PST 2012


Kenneth Rohde Christiansen <kenneth at webkit.org> has denied Hugo Parente Lima
<hugo.lima at openbossa.org>'s request for review:
Bug 79521: [Qt][WK2] Use movementStarted/Ended signals instead of movingChanged
on QtViewportInterationEngine
https://bugs.webkit.org/show_bug.cgi?id=79521

Attachment 128787: Patch
https://bugs.webkit.org/attachment.cgi?id=128787&action=review

------- Additional Comments from Kenneth Rohde Christiansen
<kenneth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=128787&action=review


Almost there!

> Source/WebKit2/UIProcess/qt/QtViewportInteractionEngine.cpp:129
> +    connect(m_flickProvider, SIGNAL(movementStarted()),
SLOT(panMoveStarted()), Qt::DirectConnection);
> +    connect(m_flickProvider, SIGNAL(movementEnded()), SLOT(panMoveEnded()),
Qt::DirectConnection);

I think we should rename those methods to flickableMoveStarted/Ended

> Source/WebKit2/UIProcess/qt/QtViewportInteractionEngine.cpp:-193
> -    if (m_flickProvider->isMoving()) {
> -	   if (m_scrollUpdateDeferrer)

Can be please assert for this inside the panMoveStarted/Ended to ensure that
the state is always correct?


More information about the webkit-reviews mailing list