[webkit-reviews] review granted: [Bug 78647] Switch drawLineForBoxSide to use integers : [Attachment 128525] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 23 13:57:55 PST 2012


Eric Seidel <eric at webkit.org> has granted Levi Weintraub <leviw at chromium.org>'s
request for review:
Bug 78647: Switch drawLineForBoxSide to use integers
https://bugs.webkit.org/show_bug.cgi?id=78647

Attachment 128525: Patch
https://bugs.webkit.org/attachment.cgi?id=128525&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=128525&action=review


> Source/WebCore/rendering/RenderBlock.cpp:2597
> +		   drawLineForBoxSide(paintInfo.context,
pixelSnappedRuleRect.x(), pixelSnappedRuleRect.y(),
pixelSnappedRuleRect.maxX(), pixelSnappedRuleRect.maxY(), boxSide, ruleColor,
ruleStyle, 0, 0, antialias);

Seems we should have a version of this method which takes a rect?  Possibly a
LayoutRect event...

> Source/WebCore/rendering/RenderInline.cpp:1459
> +    IntRect pixelSnappedBox = pixelSnappedIntRect(box);

I would have used "snappedBox" or something shorter.  pixelBox?  intBox?

> Source/WebCore/rendering/RenderInline.cpp:1534
> +	       pixelSnappedBox.maxY(),
> +	       pixelSnappedBox.maxX() + outlineWidth,
> +	       pixelSnappedBox.maxY() + outlineWidth,

This seems like a theme... seems like we should have a helper method to help
with this theme...

> Source/WebCore/rendering/RenderObject.cpp:1184
> +    int leftOuter = outer.x();
> +    int leftInner = inner.x();
> +    int rightOuter = outer.maxX();
> +    int rightInner = inner.maxX();

Oh, split coords, you are so error prone. :(


More information about the webkit-reviews mailing list