[webkit-reviews] review granted: [Bug 78867] [Qt] navigationType is missing in new API : [Attachment 128307] added missed const

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 22 22:31:20 PST 2012


Simon Hausmann <hausmann at webkit.org> has granted Misha
<Michael.Tyutyunik at nokia.com>'s request for review:
Bug 78867: [Qt] navigationType is missing in new API
https://bugs.webkit.org/show_bug.cgi?id=78867

Attachment 128307: added missed const
https://bugs.webkit.org/attachment.cgi?id=128307&action=review

------- Additional Comments from Simon Hausmann <hausmann at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=128307&action=review


r=me

> Source/WebKit2/UIProcess/API/qt/qquickwebview_p.h:101
> +    enum NavigationType {
> +	   LinkClickedNavigation,
> +	   FormSubmittedNavigation,
> +	   BackForwardNavigation,
> +	   ReloadNavigation,
> +	   FormResubmittedNavigation,
> +	   OtherNavigation
> +    };

I realize that one disadvantage of naming things this way around is that it's
not as auto-completion friendly as when the enum values being with a common
prefix. Anyway, this one is consistent with the other enums we have right now
as well as other enums in QtQuick, such as for example FlickableDirection { ...
VerticalFlick }, BoundsBehaviour { ... StopAtBounds }.


More information about the webkit-reviews mailing list