[webkit-reviews] review granted: [Bug 77155] [chromium] GL_CHROMIUM_gpu_memory_manager extension : [Attachment 127021] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 14 13:10:52 PST 2012


James Robinson <jamesr at chromium.org> has granted Michal Mocny
<mmocny at chromium.org>'s request for review:
Bug 77155: [chromium] GL_CHROMIUM_gpu_memory_manager extension
https://bugs.webkit.org/show_bug.cgi?id=77155

Attachment 127021: Patch
https://bugs.webkit.org/attachment.cgi?id=127021&action=review

------- Additional Comments from James Robinson <jamesr at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=127021&action=review


R=me

> Source/WebKit/chromium/public/platform/WebGraphicsContext3D.h:135
> +	   virtual void onMemoryAllocationChanged(size_t
gpuResourceSizeInBytes) = 0;

FYI in other places in the WebKit API (but not in this file) we prefer using
either willXXX() or doXXX() to make it clearer whether the callback is invoked
before or after the event in question.	In this case I think this should be
"didMemory..." since it's an async notification.

i think it's probably better to be locally consistent here and leave the name
you have, but could you file a bug on these callbacks collectively not
following the normal naming conventions?

> Source/WebKit/chromium/public/platform/WebGraphicsContext3D.h:136
> +    protected:

nit: newline before 'protected', please


More information about the webkit-reviews mailing list