[webkit-reviews] review granted: [Bug 68044] Replace old strtod with new strtod : [Attachment 126708] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 13 11:26:00 PST 2012


Geoffrey Garen <ggaren at apple.com> has granted Mark Hahnenberg
<mhahnenberg at apple.com>'s request for review:
Bug 68044: Replace old strtod with new strtod
https://bugs.webkit.org/show_bug.cgi?id=68044

Attachment 126708: Patch
https://bugs.webkit.org/attachment.cgi?id=126708&action=review

------- Additional Comments from Geoffrey Garen <ggaren at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=126708&action=review


Can you post performance results?

> Source/JavaScriptCore/ChangeLog:16
> +	   It's takes a template argument to allow clients to determine
statically whether it should allow 

Typo: "It's" should be "It".

> Source/JavaScriptCore/parser/Lexer.cpp:1331
> +		   tokenData->doubleValue =
WTF::strtod<true>(reinterpret_cast<const char*>(m_buffer8.data()), 0);

The WebKit style is to use bool in cases where the value is usually in a named
variable, but to use a named enumeration in other cases, for readability. You
should use a named enumeration in your template parameter, rather than bool.


More information about the webkit-reviews mailing list