[webkit-reviews] review denied: [Bug 77976] [Qt] Register individual WebGraphicsLayer to LayerTreeHost instead of handling the tree as a whole. : [Attachment 125881] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 7 15:42:30 PST 2012


Noam Rosenthal <noam.rosenthal at nokia.com> has denied Jocelyn Turcotte
<jocelyn.turcotte at nokia.com>'s request for review:
Bug 77976: [Qt] Register individual WebGraphicsLayer to LayerTreeHost instead
of handling the tree as a whole.
https://bugs.webkit.org/show_bug.cgi?id=77976

Attachment 125881: Patch
https://bugs.webkit.org/attachment.cgi?id=125881&action=review

------- Additional Comments from Noam Rosenthal <noam.rosenthal at nokia.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=125881&action=review


Let's fix the naming nitpicks and Kenneth's other comments; otherwise we're
good to go.

>> Source/WebKit2/WebProcess/WebCoreSupport/WebGraphicsLayer.cpp:165
>> +   
toWebGraphicsLayer(newChild)->setWebGraphicsLayerClient(m_webGraphicsLayerClien
t);
> 
> Maybe it should just be called setGraphicsLayerClient?

I don't think so... there's already a GraphicsLayerClient class.
Maybe there's a better name for this? I just didn't like "remote" in there
because it made the code confusing to read.

>> Source/WebKit2/WebProcess/WebCoreSupport/WebGraphicsLayer.h:60
>> +	virtual void releaseLayer(WebCore::WebGraphicsLayer*) = 0;
> 
> This is a bit confusing, register vs release. Add a comment ?

Maybe attachLayer / detachLayer?

> Source/WebKit2/WebProcess/WebPage/qt/LayerTreeHostQt.cpp:61
> +    for (HashSet<WebCore::WebGraphicsLayer*>::iterator iter =
registeredLayers.begin(); iter != end; ++iter)
> +	   (*iter)->setWebGraphicsLayerClient(0);

iter -> it


More information about the webkit-reviews mailing list