[webkit-reviews] review denied: [Bug 77096] Web Inspector: [Meta] Allow emulation of touch events : [Attachment 125615] [PATCH] Return error from agent method if touch events are not enabled in webkit

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 6 06:32:01 PST 2012


Pavel Feldman <pfeldman at chromium.org> has denied Alexander Pavlov (apavlov)
<apavlov at chromium.org>'s request for review:
Bug 77096: Web Inspector: [Meta] Allow emulation of touch events
https://bugs.webkit.org/show_bug.cgi?id=77096

Attachment 125615: [PATCH] Return error from agent method if touch events are
not enabled in webkit
https://bugs.webkit.org/attachment.cgi?id=125615&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=125615&action=review


> Source/WebCore/inspector/InspectorDOMAgent.cpp:409
> +    m_document->settings()->setTouchEventEmulationEnabled(enabled);

You should do this via the page agent.

> Source/WebCore/inspector/InspectorDOMAgent.cpp:1069
> +    m_state->setBoolean(DOMAgentState::touchEventEmulationEnabled, enabled);


You should move this into the updateTouchEventEmulationInPage.

> Source/WebCore/inspector/front-end/SettingsScreen.js:42
> +    var p = this._appendSection(WebInspector.UIString("General"));

I think we should rename "Network" to "User Agent", move Disable cache into
"General"


More information about the webkit-reviews mailing list