[webkit-reviews] review granted: [Bug 105264] Percentage min/max width replaced element may incorrectly rendered : [Attachment 180424] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 20 15:40:45 PST 2012


Tony Chang <tony at chromium.org> has granted KyungTae Kim <ktf.kim at samsung.com>'s
request for review:
Bug 105264: Percentage min/max width replaced element may incorrectly rendered
https://bugs.webkit.org/show_bug.cgi?id=105264

Attachment 180424: Patch
https://bugs.webkit.org/attachment.cgi?id=180424&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=180424&action=review


> Source/WebCore/rendering/RenderBox.cpp:2418
> +LayoutUnit RenderBox::computeReplacedLogicalWidth(ComputeType computeType)
const

computeType is very vague.  Please use something like shouldComputePreferred
for the variable name.

> Source/WebCore/rendering/RenderBox.h:43
> +enum ComputeType { ComputeActual, ComputePreferred  };

I would probably name it something like: enum ComputePreferred {
ShouldComputeActual, ShouldComputePreferred };

> Source/WebCore/rendering/RenderReplaced.h:35
> +    virtual LayoutUnit computeReplacedLogicalWidth(ComputeType  =
ComputePreferred) const;

OVERRIDE


More information about the webkit-reviews mailing list