[webkit-reviews] review granted: [Bug 104593] Add in-band text track cues only once : [Attachment 179832] Fix style errors

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 17 17:12:51 PST 2012


Dean Jackson <dino at apple.com> has granted Eric Carlson
<eric.carlson at apple.com>'s request for review:
Bug 104593: Add in-band text track cues only once
https://bugs.webkit.org/show_bug.cgi?id=104593

Attachment 179832: Fix style errors
https://bugs.webkit.org/attachment.cgi?id=179832&action=review

------- Additional Comments from Dean Jackson <dino at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=179832&action=review


> Source/WebCore/html/track/InbandTextTrack.cpp:154
> +	       if (!cue)
> +		   return false;
> +	       if (cue->startTime() != startTime)
> +		   return false;
> +	       if (cue->endTime() != endTime)
> +		   return false;
> +	       if (cue->text() != content)
> +		   return false;
> +	       if (cue->cueSettings() != settings)
> +		   return false;
> +	       if (cue->id() != id)
> +		   return false;

Is there any reason you chose this form over a single if statement? It is
easier to read :)

> LayoutTests/media/track/track-in-band-cues-added-once.html:4
> +    <head>
> +	   <meta http-equiv="Content-Type" content="text/html; charset=utf-8"
/>

No title?


More information about the webkit-reviews mailing list