[webkit-reviews] review denied: [Bug 100754] Faster sorting of numeric arrays : [Attachment 173755] Patch and tests

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 14 12:16:39 PST 2012


Oliver Hunt <oliver at apple.com> has denied Cosmin Truta <ctruta at gmail.com>'s
request for review:
Bug 100754: Faster sorting of numeric arrays
https://bugs.webkit.org/show_bug.cgi?id=100754

Attachment 173755: Patch and tests
https://bugs.webkit.org/attachment.cgi?id=173755&action=review

------- Additional Comments from Oliver Hunt <oliver at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=173755&action=review


This looks good, the only complaint i have is using a bool to indicate sort
direction - i'd rather have an enum, that's the direction we've been moving in
for a while now.

> Source/JavaScriptCore/runtime/JSArray.h:69
> -    void sortNumeric(ExecState*, JSValue compareFunction, CallType, const
CallData&);
> +    void sortNumeric(ExecState*, JSValue compareFunction, CallType, const
CallData&, bool ascendingOrder);

I don't like this bool, replace it with an enum -- say enum SortOrder {
SortAscending, SortDescending };


More information about the webkit-reviews mailing list