[webkit-reviews] review granted: [Bug 104074] Web Inspector: Add command for dispatching mouse events : [Attachment 178584] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 10 10:38:07 PST 2012


Pavel Feldman <pfeldman at chromium.org> has granted Ken Kania
<kkania at chromium.org>'s request for review:
Bug 104074: Web Inspector: Add command for dispatching mouse events
https://bugs.webkit.org/show_bug.cgi?id=104074

Attachment 178584: Patch
https://bugs.webkit.org/attachment.cgi?id=178584&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=178584&action=review


> Source/WebCore/inspector/InspectorInputAgent.cpp:134
> +	   modifiers ? *modifiers & PlatformEvent::ShiftKey : false,

you could do int convertedModifiers = modifiers ? *modifiers : 0; to improve
the readability here.

> LayoutTests/inspector-protocol/input/dispatchMouseEvent.html:57
> +	       InspectorTest.sendCommand("Input.dispatchMouseEvent",
events.shift(), continueTest);

As with keyboard, these will be naturally serialized, so you don't need to wait
for previous command to finish in order to start the new one. You only need to
wait for the last one to complete before calling completeTest()


More information about the webkit-reviews mailing list